Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Development Tools Introduction to Git GitHub and Other Remote Repositories Pushing Commits to GitHub

Wojciech Chomanski
Wojciech Chomanski
Front End Web Development Techdegree Student 8,582 Points

is there a way to work around this issue Support for password authentication was removed on August 13, 2021. ???

How can i fix this issue Support for password authentication was removed on August 13, 2021. Please use a per
sonal access token instead. or how dose it works to use such a token?

5 Answers

I was able to successfully push to my repo. There are a few things I would recommend checking:

  1. Verify your username is correct. You can do this by signing into Github, and clicking on your profile icon in the top right corner. It will say "Signed in as <your username here>". I was also able to successfully sign in using the email address tied to my account as the username, so you could try this as well if your Github username is not working.

  2. Create a new key and ensure the expiration date is set to a date in the future. I recommend no more than a day because the key you are creating is being used on a public machine. Also, check all the boxes for permissions to ensure the token has required access to make a push.

  3. When making the git push from the Workspace, manually type the key in when prompted for the password. Copy paste does not seem to work in the Workspace, and I don't believe there is an option in the app to paste clipboard contents. This will require absolute percision, so type slowly.

  4. Whether you are successful or not, don't forget to delete this access token once you are done! You do this on the same page where the 'generate access token' button is found.

I hope this helps. Best of luck!

I wasn't able to manually type the token. Once I enter my username and then get the password prompt my cursor just blinks and I cannot enter any characters?

Adam Bagby
Adam Bagby
3,849 Points

I just worked through this issue for a bit and this is the solution, but... for complete beginners like me, this answer wasn't super clear. I found other info on other questions to piece together.

  1. In step 2 of this answer "create a new key" means a personal access token - see these instructions: https://stackoverflow.com/questions/68775869/support-for-password-authentication-was-removed-please-use-a-personal-access-to

  2. In step 3 of this answer, it is true that you can't copy/paste and it is true that you can just type the token in directly, but I see that I am not the only one who was confused by the fact that when you type nothing actually appears visually, but it is being input. just type carefully to get your token right and then it should work. again, you won't see the token being typed out but when you've typed it in and then hit enter, you push should be completed.

Mahmud Kurniawan
Mahmud Kurniawan
7,139 Points

You can use PAT (Personal Access Token) for replacement of password. So, you type personal access token instead of password if they asked you github password.

Read the forum and the articles below to how create PAT:



You can obtain a PAT by selecting <>Developer Settings on your profile, but you cannot copy/paste from GitHub to 'workspaces'. When I attempt to type my PAT the cursor only blinks and won't let me type.

Erik Embervine
Erik Embervine
Python Development Techdegree Student 2,442 Points

thanks for posting, this worked for me as well (as of today, 25 Oct 2022). initially i tried using a Fine Grain Token as recommended by GitHub but it didn't work (apparently it is still in Beta testing). so i created a Personal Access Token (classic) instead in the same Developer Settings section on GitHub, checked all the boxes for permissions scope, generated the token, copied it to clipboard, and tried the git push -u origin master command again. i entered my username, and for the password prompt i pasted the Personal Access Token and the push succeeded without errors. it seems GitHub uses tokens now in place of the old password paradigm for https connections.

That is why I stated 'This will require absolute percision, so type slowly' in step 3. You'll find this is common (although annoying) when typing secrets into a prompt. This is a security feature so that someone looking over your shoulder cannot see the security key, or even know it's length.