Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Issue running Anaconda Navigator

After installing Anaconda, I wasn't able to open the navigator. I currently have Python 3.7 (64 bit) installed and installed the most recent 64 bit anaconda exe for windows. When I run the navigator, a black command prompt screen pops up, disappears, and another pops up and disappears again. In Anaconda Prompt I cannot run any commands, i ran

conda info

and got the following error:

# >>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

    Traceback (most recent call last):
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\exceptions.py", line 819, in __call__
        return func(*args, **kwargs)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\cli\main.py", line 78, in _main
        exit_code = do_call(args, p)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\cli\conda_argparse.py", line 77, in do_call
        exit_code = getattr(module, func_name)(args, parser)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\cli\main_info.py", line 317, in execute
        info_dict = get_info_dict(args.system)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\cli\main_info.py", line 171, in get_info_dict
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\base\context.py", line 400, in pkgs_dirs
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\base\context.py", line 416, in _user_data_dir
        return user_data_dir(APP_NAME, APP_NAME)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\_vendor\appdirs.py", line 67, in user_data_dir
        path = os.path.join(_get_win_folder(const), appauthor, appname)
      File "C:\Users\brand\Anaconda3\lib\site-packages\conda\_vendor\appdirs.py", line 284, in _get_win_folder_with_pywin32
        from win32com.shell import shellcon, shell
    ImportError: DLL load failed: %1 is not a valid Win32 application.

`$ C:\Users\brand\Anaconda3\Scripts\conda info`

I tried uninstalling, disabling my antivirus, and reinstalling, but still have the same problems.

1 Answer

Are you sure you are currently running on windows 64? If you look at the last error message, it looks like it is looking for a windows 32 application

Yes, it says 64-bit OS and x64-based processor in system settings

One possibility is that you have a corrupt file or it did not download completely. When you tried uninstalling, did you ensure all of the data was completely gone as well?

Checking my path variables, I had one set to both the 32 bit and 64 bit versions of python, after removing the 32 bit, it seemed to resolve the issue entirely. Also I had to revert to python 3.6.5. So it did seem to be a clash between the 32 bit and 64 bit after all.