Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS

Shane Aycoth
PLUS
Shane Aycoth
Courses Plus Student 1,693 Points

Issue with 3rd challenge question under More Pseudo-classes.

The request is to Create a new rule that selects the disabled field only (in the 'Phone' field of the HTML) and set bkgd to lightgray.

I entered the markup below and the correct field changed to light gray after refresh. However, it gave me the bummer check css selector. So I typed the attribute 'input' before the Pseudo-class and thought I had it since the field changed to light gray but I'm still getting the bummer message. Am I missing something? Please help, would like to move forward.

:disabled { background-color: #CCC }

5 Answers

Nikolaos Papathanassopoulos
Nikolaos Papathanassopoulos
10,322 Points

its probably just:

:disabled { background-color: lightgray; }

just noticed did you set the closing ';' at the end?

Shane Aycoth
PLUS
Shane Aycoth
Courses Plus Student 1,693 Points

THANKS! That was it. lightgray instead of #CCC. I did have the closing.

Nikolaos Papathanassopoulos
Nikolaos Papathanassopoulos
10,322 Points

I know the challenges can be tricky sometimes ;) But its even more rewarding if you figure it out by yourself ;)

it's kind of silly, in the real world you don't need a semicolon if you only have one atribute.

Michael Morton
Michael Morton
4,902 Points

I've done the same code challenge without the semicolon on single attributes. Seemed to work fine for me.

But I've learned to put the semicolon there for single attributes to get into the habit of best practices.

@ Daniel Whyte - Nice website sir!