Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Issue with eclipse.

Using the bundle kit from the start of understand android app making and for some reason I cannot create new projects. It will not allow me to get past the starting screen for the new project.

I cannot select a compiler for it. it shows no compiler for me to select. I am using a pc and not mac. 64 bit system have tried both 64 bit and 32 bit for pc.

2 Answers

Eclipse should automatically build, compile, and run your projects when you run them. Try reinstalling Eclipse or the Android ADT bundle/SDK and make sure that Eclipse is pointing to the proper Android SDK.

Akhtar Hussain
Akhtar Hussain
880 Points

I had this exact same problem. My Android Development Bundles was in 'My Documents' and my eclipse workspace was in my 'C:\Users\my-name\'.

So what I did, I deleted everything I had from before and unzipped my Android Development Bundle again in C:\Users\my-name. And then, I ran the 'initial_setup.bat' again. Worked fine afterwards. :)