Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML How to Make a Website Responsive Web Design and Testing Website Testing

Issue with validation

Is anyone else getting Line 7, Column 140: Bad value http://fonts.googleapis.com/css? family=Open+Sans+Condensed:300,700,300italic|Allan:400,700 for attribute href on element link: Illegal character in query: not a URL code point. โ€ฆns+Condensed:300,700,300italic|Allan:400,700' rel='stylesheet' type='text/css'> Syntax of IRI reference: Any URL. For example: /hello, #canvas, or http://example.org/. Characters should be represented in NFC and spaces should be escaped as %20 when they go to validate their code. With the only thing red being the ">"?

7 Answers

I decided to paste your link into the validator to see what was going on and that's when I finally noticed the space between the ? and family.

If you have the %7C in and you remove the space then i think you'll be good.

Remove that space and let me know.

Hi Jennifer,

The pipe character | is causing the error. You have to url encode it with %7C. So replace the pipe character in the path with that code.

Not sure why google is giving the url's like this.

Thank you for the help Jason. I tried that and it said the same thing but the > is underlined and red. Is there anything else it could be or should I just ignore it?

and when I hover over it says "position where error occurred." Its so weird!

Well, here's the other post for reference. https://teamtreehouse.com/forum/error-during-the-w3c-markup-validation

It seems like you have the same error. You replaced the vertical bar with %7C? Is there more than one vertical bar in the url?

Post the entire line with the link tag. Maybe it's something else.

I tried to post tag but it wouldn't let me. I will try and see what else I can do after reading the other post. Thank you again.

Here's a post with some tips on how to post code: https://teamtreehouse.com/forum/how-to-type-code-in-the-forum

<link href='http://fonts.googleapis.com/css? family=Open+Sans+Condensed:300,700,300italic%7cAllan:400,700' rel='stylesheet' type='text/css'>

Straight from the validator

When posting code you want to make sure that you have a blank line first. then 3 backticks on the next line. The backtick should be over your tab key.

On the next line after your backticks you paste your code and then you go to a new line and enter 3 more backticks.

That comment was before I noticed you fixed your code.

It should look something like this after you url encode the pipe character:

<link href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed:300,700,300italic%7CAllan:400,700' rel='stylesheet' type='text/css'>

That work! Awesome! Thank you! Funny thing is it looks exactly like what I had before in the video.....