Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS Build a Simple iPhone App with Swift Running Apps On a Device Running on Device

It states that my phone is an unsupported architecture, and Xcode cannot locate my device support files

When I link my Iphone 11 to my macbook pro, it states that my iphone is an unsupported architecture and that my iphone does not support any of FunFacts.app's architectures. And that I have to add my phone's arm64e architecture to FunFacts.app's Architectures build setting. How do I do that??? Thanks!

3 Answers

I get this from time to time - usually it's resolved by cleaning the project (Product > Clean Build) and then try running the project again. If that doesn't work, we may need to play with your targets.

I just cleaned my project and tried running the project again, but it still says that my iphone 11 is running iOS 13.3.1 (17D50), which may not be supported by this version of Xcode. But I checked that my Xcode is indeed the newest version on the app store.....How do I fix that? And how do I play with my targets?? Thanks!!

It sounds as if the target in your project may be above 13.3.1. When Xcode updates it can default to the latest iOS (13.3.4) in new projects.

If you change your target to 13.0 it should work fine. Do this by clicking the blue project icon in the top left, and then under targets in the central left panel select the top icon with the iconic pencil / ruler icon. You'll then be able to select 13.0 as your new target and that should work. These Images should help.

If you don't get any luck just give me a shout 👍

I tried to change the target to iOS 13.0, but then it seems like my highest deployment target option only reaches iOS 11.4. When I manually change the Deployment target and type down iOS 13.0 , it now pops up a Target Integrity yellow triangle that says "iOS Deployment Target 'iOS 13.0' is newer than SDK 'iOS 11.4' in target FunFacts. "

What should i do? Thanks for the help!

The best way forward is probably to upload your project so I can run it here to see if I can reproduce the error - if I can I'll figure it out this end and send it back with details of the error 👍

Thanks so much! How should I upload my project from Treehouse up here then???

Feel free to upload it to a repo or via dropbox / google drive etc 👍

thank you so much, I pasted the download link of my project in the google drive below.