Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Jammed with my first lesson: Installing Ruby

Hi everyone, I'm new around here and got jammed just starting the installation of Ruby due to (probably) different versions and scenario so for now I just purchased my OSX upgrade (from 10.6.8 to 10.8) and will try again tomorrow (hopefully) with a new installation.

What would be the best way to clean absolutely everything I did installing GIT, RVM, etc, hopping to get a fresh install?

BTW I was ok following the install, etc on the RUBY ON RAILS setup so not sure if I actually overwrote anything when trying RUBY (after RoR).

13 Answers

Ok, quick update here just to share that I'm now running OSX 10.8.2 just didn't have the chance to go over the installation again so probably all mess from yesterday is still there and because of time constraints I just decided to watch few more of the GREAT videos of TeamThreeHouse but have not dig into the installation part again.

I assume I can just follow Jason Seifer instructions again and hopefully all i did previously will be overwritten and I'll be back to normal.

BTW what I think caused the issue in my case is that I followed instructions from in "Installing Rails (Mac)" by Jim Hoskins and got that working so when I got to the point of 'back to roots' (following Rob recommendation answering a pre-sales question of mine) that's probably where all got a messed since Ruby was already running after I followed Jim's instructions.

Another thing here (trying to give my experience hopping this will help improved) is that I guess all the PRO guys here use different tools so when I watched Jim video he talked about using SUBLIME TEXT 2 as editor (so I did follow instructions and installed) and then Jason uses something else. At that point I researched a bit more and find out that SUBLIME seem to be like a paid tool (according to site it'll work OK for free for limited time only) so I can understand that every PRO uses their preferred tools but it'll be help to have some kind of recommendation to follow as a standard during TreeHouse training just so that we don't get confused with this.

Anyhow just wanted to update here what's going on in my end. I'll be back online in few hours to follow up either with training videos or trying complete install following Jasons instructions again.

Hey Ricardo.

Sublime Text 2 is what you'll see being used in most of the videos at Treehouse. It has what is called an 'unlimited trial', so you can continue to use it for as long as you go through training here - and basically purchase a license when you feel you're ready.

It is a great application, very popular - and it lets you use the same application as Treehouse (I think in some of the older videos they used Coda or Textmate)

Check out the "Building a Simple Ruby on Rails Application > Getting Started with Rails" - the "Installing a Text Editor" video.

If you want further instruction on how to set up sublime, and to create a symbolic link - so you can launch Sublime Text 2 from the terminal using the command 'subl', check out the free video at the Pragmatic Bookshelf


If you still need help getting set up, let us know - the community here is very helpful.

Thank you for the info, sorry I didn't email back earlier but after upgrading my Mac to 10.8.2 week had keep me busy enough not allowing me to continue with this journey but will re-take it and report back.

Thanks for the help and useful info :)

Ok here's my latest update (while downloading a 1.61GB file - makes sense?)...

After recently upgrading my OSX to 10.8.2 and started following Jason's video (http://bit.ly/TZH6HB) step by step until minute about 4 or so when I had to execute:

** brew install git **

but then got:

Warning: A newer Command Line Tools for Xcode release is avaliable You should install the latest version from: http://connect.apple.com Error: Could not create /usr/local/Cellar Check you have permission to write to /usr/local

Hmm.., when searching came across with "...After following many outdated and incomplete instructions for setting up a web development environment on a Mac.." (@ http://bit.ly/TZHrK7) THAT MADE A LOT OF SENSE TO ME so I followed the lead to find out that I needed to go to AppleStore and get latest "Xcode" but then found myself downloading 1.61GB which I hope it makes sense and will most probably complete downloading overnight while I sleep.

Anyway I guess I should just run that install and then follow up with instructions on the video I'm just sharing my progress here to double check with the pros in case I'm doing something wrong and at least this would help to document the procedure

Thank you for the info, sorry I didn't email back earlier but after upgrading my Mac to 10.8.2 week had keep me busy enough not allowing me to continue with this journey but will re-take it and report back.

Thanks for the help and useful info :)

Finally: I think I got it all figured out. It really took me a lot of troubleshooting to research one step at a time but I think I finally got it.


James Barnett
James Barnett
39,199 Points

@Ricardo -

Did you take step-by-step notes, you can share to help out other people with solving similar issues in the future?

+1 for troubleshooting your own problems.

Actually.. my issue is not fixed after all but I should be close to completion now.

ERROR I GET IS: "There has been an error while running configure. Halting the installation."

I'm pasting the whole thing at the bottom of this email but after some more research and testing I guess problem is that XCode was downloaded and installed but "COMMAND LINES TOOL" was not so I'm currently downloading and it seems (or that's what I guess at least) that problem will be solved after that so thank you for whoever want/can to comment in here but I wanted to share how things are from this side at the moment.


No binary rubies available for: downloads/ruby-1.9.3-p362. Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies. Installing Ruby from source to: /usr/local/rvm/rubies/ruby-1.9.3-p362, this may take a while depending on your cpu(s)... ruby-1.9.3-p362 - #downloading ruby-1.9.3-p362, this may take a while depending on your connection... ruby-1.9.3-p362 - #extracted to /usr/local/rvm/src/ruby-1.9.3-p362 (already extracted) Patch segfault_fix_7629 was already applied. ruby-1.9.3-p362 - #configuring Error running 'env LDFLAGS=-L/opt/sm/pkg/active/lib CFLAGS=-I/opt/sm/pkg/active/include CPATH=/opt/sm/pkg/active/include ./configure --enable-shared --disable-install-doc --prefix=/usr/local/rvm/rubies/ruby-1.9.3-p362 --with-opt-dir=/usr/local/rvm/usr', please read /usr/local/rvm/log/ruby-1.9.3-p362/configure.log There has been an error while running configure. Halting the installation.

That didn't do it :(

Any clue?

BTW among many other things already tried and tested with no luck.... I also tried

brew install ruby-build --HEAD


Please, commit your changes or stash them before you can merge. Aborting Error: Failure while executing: git pull -q origin refs/heads/master:refs/remotes/origin/master

Well,.. little update here after not so much sleep last night.

I may have nailed it using instructions here: http://bit.ly/UZvK3z however I'm not certain that my installation is up to date now and I'm scared of running any other 'brew', 'update', 'upgrade' or similar without the proper advice so this time I'm here really hopping to get some guidance from the PROs.

BTW from previous link I was able to run it all until I got to where it says:

"Configure a Ruby Application" "Configure Rails Application"

...so that was not done.

To better explains my scenario, this is what I get when typing...

A). ruby -v: ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]

B). ruby -ver:

ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0] -e:1: undefined local variable or method `r' for main:Object (NameError)

C). irb -v: irb 0.9.5(05/04/13)

MY OVERALL ENVIRONMENT: Mac OSX 10.8.2 (Mountain Lion) XCode (latest from apple) was installed but again it ultimately executed after (probably outdated) instructions at http://bit.ly/UZvK3z

Any PRO around here, please... advice welcome :)

BTW I'll be changing my HDD tomorrow Monday so I'll have a complete back up of my exact HDD so if I get any feedback about "hey Ricardo, just run XYZ and you should be fine updating all your gems and ruby related things..." that'll be fantastic since that will be the perfect scenario considering I'll have an exact copy of what I have in case I need to roleback....

Hi again... not sure if anybody follows this up at all but just thought about stopping back to confirm that this is no longer needed... just in case.