Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS Build an Interactive Story App with Swift 2 Refactoring the Model Layer Dismissing the Keyboard

Keyboard does not appear

Hi My keyboard does not appear when I click on the textfield. Instead it just takes input from my keyboard. It has been working fine before this method. My code looks just like pasan's. My keyboard also did not contain a "Done" button. It was a "return" button instead.

1 Answer

Steven Deutsch
Steven Deutsch
21,046 Points

Hey Alexander La Bianca,

So you have two issues to resolve:

1) Your keyboard is not showing up in the simulator.

You can show the keyboard by going into the menu for simulator Hardware -> Keyboard -> Toggle Software Keyboard

2) You need to change the return key from "Return" to "Done"

You can do this through the utilities panel in Xcode. Just select the text field and then go to the attributes inspector. You will see an option for "Return Key". Select the "Done" option from the drop down menu. You will need to do this for all text fields you want this change to appear on.

Good Luck!

Jason Anders
Jason Anders
Treehouse Moderator 145,624 Points

Thanks Steven Deutsch!

That just happened to me in the next set of videos, and I had no clue what happened. Seems like a weird setting to just randomly change itself??

:dizzy: