Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Learning Ruby on a windows machine


Am I in for a world of pain doing the Ruby on Rails project using windows 8.

I'm taking the beginners project and I'm struggling on pretty much the very first step. When I load up statuses in the browser I get this,

  ExecJS::RuntimeError in Statuses#index

I've been searching the forum for answers and it seams there are a tun of different solutions, some of which work for some and not for others.

I tried installing nodejs but it didn't work, then I found a link to a solution on stack overflow which suggested I paste this into the command prompt;

set PATH=%PATH%;C:\Program Files\Nodejs

So I tried that and now I've broken it completely, I now get this in the browser;

  "Oops! Google Chrome could not connect to"

I guess I'll need to deinstall everything and start over.

Somebody on here mentioned nitrous.io

I'd be interested to know what you guys think, maybe I'll start saving for a Mac. Anyone having good experiences using nitrous.io so far?


4 Answers

David Curtis
David Curtis
11,301 Points

Hi Michael. I recently finished a Rails bootcamp that I took on a Win8 machine. Since then, I switched to a Macbook Pro. While Rails development can certainly be done on a Win computer, I would suggest saving for a Mac if you are interested in seriously pursuing development. I had a lot of issues that were just Win related during the course, and like you, ran into Win related issues here on Treehouse, too. YMMV. Good luck!

Hi David, thanks dude, I'm beginning to realize why people rave about macs so much. I'm going to make use of an IDE until I can afford a mac.

Stone Preston
Stone Preston
42,016 Points

try adding execjs and therubyracer to your gemfile.

gem 'execjs'
gem 'therubyracer'

then running bundle install and see if that fixes it

Thanks Stone, I'll give that a try and let you know how it goes. I'm doing the deep dive on console foundations to help me along.

Stone Preston
Stone Preston
42,016 Points

thats a good idea. there is a lot of command line involved with rails development, so its probably good you do that first

David Curtis
David Curtis
11,301 Points

Your welcome! I also briefly tried out nitrous.io and didn't have any problems with it, so I would recommend giving it a good shot. I was very anti-Apple for a long time, but I absolutely love this machine. :)