Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS CSS Basics (2014) Basic Selectors Pseudo-Classes

Adam Blake
Adam Blake
253 Points

Links Are not Orange

a:link { color: orange; }

Bogdan Cabaj
Bogdan Cabaj
16,335 Points

Is your css linked correctly? Does anything else change with css? Could it be that those links are already visited and it's showing a:visited link instead?

a:link - a normal, unvisited link a:visited - a link the user has visited a:hover - a link when the user mouses over it a:active - a link the moment it is clicked

It's hard to tell without more code.

I did the objectives for pseudo-classes now and it worked for me. It looked like this: a:link{ color:orange; } a:visited{ color:steelblue; } a:hover{ color:tomato; }

you can also look at the link from the HTML-file to the css file. sometimes the Connection can be wrong. <link rel="stylesheet" type="text/css" href="style.css">

or if it is in another catalog: <link rel="stylesheet" type="text/css" href="css/style.css">

Hope it can help! To me it looks like you have thought right.

Hi Adam, I ran into the same problem. But I was able to fix it after I closed the website and cleared the history of the past week of Chrome and Safari. After doing so, when I open the website, all my links are orange. Hope it helps

4 Answers

After spending much time on this ( a:link {color:orange} ) and not seeing orange, treehouse randomly prompted me saying my workspace stopped working and it was closed and when I re-opened, my pseudo classes were working. Maybe try closing and re-opening the work spaces. The spacing, format are no different than normal css selectors. As long as you have a:link, and follow regular css formatting, it should work. As long as you understand the concept I wouldn't spend too much time on this problem, just continue on with the video.

For me, the problem was solved by closing the window with the Lake Tahoe page, and then opening a new preview from the workspace.

I had the same problem. I closed the browser (Safari) and opened it back up in chrome, to solve the problem...for now.

Sorry for digging this up, but I also have the same problem here and after how many times I try to reload the page even with ctrl-F5 it still didn't work. So that I close the old Workspace and open the new one, logging another code, then it work correctly like the video.