Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Java Introduction to Functional Programming Java's Functional Toolset Using forEach

Phil Spelman
Phil Spelman
6,664 Points

Local Code Challenge - Cannot complete | Java 9 | IntelliJ | Gradle error | Walk-through video not working

I am attempting to complete the Local Code Challenge in the Java's Functional Toolset lesson. The video walk-through only appears as a picture so I cannot watch it :(

Re: the challenge: I have downloaded the files for the challenge, imported to IntelliJ, and edited the code to perform the desired behavior (a declarative version of the imperative example). The code works correctly when I run it.

The Gradle import does not work: Error:BUG! exception in phase 'class generation' in source unit 'BuildScript' unsupported Target MODULE

I tried to start a new Gradle project and this same error occurred, so I looked for info on the Google. Apparently other people are having this issue with Java 9 (see link below). I will try again after installing Java 8 but I'm going to skip the question for now so I can continue with the lesson. https://youtrack.jetbrains.com/issue/IDEA-171520