Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Kirk Seton
Kirk Seton
1,503 Points

Local host setup with MAMP PRO problem

The problem: I was trying to set up local hosting with MAMP PRO and I followed the lesson on local WordPress Development and MAMP but found it difficult to transfer an existing WordPress sites back for local hosting – missing content files and not able to update plugins/themes locally form the site that I originally built live on WordPress.org. Error message. (Unable to locate WordPress Content directory (wp-cntent).

The solution: I finally figured out what my issue was with regards to my question above. I did not have my Disk Permissions set up properly in MAMP PRO for local hosting it needed to be set up like this (Owner: Current: _www) and (Group: Current: _www).

This might help anyone that has encountered this issue/problem?

Also, an interesting setup for WP Multisite set up. http://premium.wpmudev.org/blog/local-wordpress-test-environment-mamp-osx/


Changing Owner and Group to _www does allow one to download and upgrade plugins via direct method, and all uploads to media library work as well, but on my MAMP Pro 3, it does not allow me to write to style.css and other files in themes. I have to revert back to my user as Owner and admin for Group.

I've seen suggestions about adding _www to the Owners group, like this one:


but I could not get this to work for me. Permissions on MAMP Pro 3 have been very frustrating, and I can't seem to find an definitive solution for this. It shouldn't be this difficult, but it is, and I'd love to find a good solid solution that works for everyone.

-- Lee

3 Answers

Storm Farrell
Storm Farrell
2,525 Points

Just in case anyone else has this issue, I solved it by going to MAMP PRO General settings tab, and changing 'Run Apache/MySQL server as user:' to my <username>, not www.

Then with my Sites folder permissionsset to Owner: <username> everything seemed to work fine. No need to further update my permissions.

Zac Gordon
Zac Gordon
Treehouse Guest Teacher

Thanks Kirk Seton for posting up this tip for folks on Local Disk Permissions and MAMP setup!

Storm Farrell
Storm Farrell
2,525 Points

Yea, I have the same problem as Lee. I constantly have to change permissions, depending on whether I'm working the files, or from the WordPress dashboard. Surely there must a catch all permissions settings that will allow access for both?