Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress

Victor Ibasco
Victor Ibasco
11,035 Points

MAMP Access Denied - phpMyAdmin issues - Following WordPress Track

I can't include pictures ?! That's TERRIBLE ! I had no clue. I guess i'll try my best to do so without them.

This is the following error that I get when I attempt to open MAMP's phpMyAdmin panel.

Welcome to phpMyAdmin

Error

MySQL said: Documentation Cannot connect: invalid settings.

mysqli_real_connect(): (HY000/2002): No connection could be made because the target machine actively refused it.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

I had already searched Stack OverFlow / YouTube / Forum posts and I could not debug this. Partly because I got plenty lost in peoples' solutions.

What I had done was that I created (2) databases because the first one had given me an error in either User / Pass / Host name when attempting to finish the WordPress download. I proceeded to create another database to access and ended up with this.

I understand that I had created a new username and password. I don't believe that I changed any root user or pass. I had refreshed the page and all of a sudden this came up.

I had also uninstalled MAMP from everywhere and reinstalled it.

Thanks, Victor

Victor Ibasco
Victor Ibasco
11,035 Points

Maybe it would be helpful to add that I had already previously installed and used mySQL and it was using port 3037. When MAMP was installed it asked me to either download over it or use the next available port. I used the next available port.

I also checked config.inc.php file to check if root user or pass was changed. They weren't, they were both, 'root'