Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Ruby Foundations Ruby Basics Installing Ruby

David Langley
David Langley
10,965 Points

mate command not found ?

I followed all the instruction in your video however when I got to the line where we enter;

mate ~/.bash_profile

I get;

command not found

I reinstalled text mate thinking it might have something to do with that, no good.

Any ideas ? thanks in advance.

3 Answers

David Langley, TexMate has a spot in the preferences to install the command.

<img src="http://i.imgur.com/h6fOeRQ.png"></img>

Looks like the instructions miss this, cc'ing Jason Seifer

ever get an answer? would love one

Richard Potts
Richard Potts
2,760 Points

I'm having the same problem, can anyone help?

Kevin Hackett
Kevin Hackett
10,441 Points

Open up Textmate and go to the preferences menu. Click on the terminal tab at the top.

The first section will explain what to do.

If you have a mac, you can open up the .bashrc file in textedit using the following command: open -e .bashrc

Add this line to the top of the file: export EDITOR="/usr/local/bin/mate -w"

Save and close out

Back in terminal tab within preferences in textmate, click the Install button and that should be everything good to go.

Thanks for posting this guys I was having this exact problem and the answers here definitely helped me :)