Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Data Analysis Data Analysis Basics Getting to Know Your Data Summarizing Data: Maximum, Minimum, Range

Erlend Dybvik Indrelid
Erlend Dybvik Indrelid
5,843 Points

Min function doesn't work: no output

Hi! I recently started the data analysis track, but stumbled upon something weird when using Google Sheets.

When I tried to do the =MIN() function in the Summary sheet, the output was 0 instead of the minimum time used. I selected the row correctly, excluding the title "Official Time" row, so the selection would only include the time formats. However, the output was still 0, so I tried to change the format of the numbers by selecting the drop down menu under "123". I tried changing it to "duration", but to my surprise, it didn't work. I also tried all of the other settings in the drop down menu.

This is the function I used, which is indeed the exact same as the teacher used: =MIN('2017'!S2:S26411)

Thanks for the help, and have a nice day!

You can create a shareable link that anyone can view by clicking share, then 'get shareable link' in the upper corner. That may be useful to others in helping you.

3 Answers

I was able to recreate what you see by copying your data to a new sheet (something I could edit). If the numbers in a column are left aligned, usually that means they are in a text format. If they are in a numerical format they will be right aligned. Your column S data in 2017 is left aligned.

By clicking the S header to select the entire column, then menu Format > Number > Duration, the data right aligned and the MIN function displayed the correct value.

Erlend Dybvik Indrelid
Erlend Dybvik Indrelid
5,843 Points

Thank you for the reply.

For some weird reason, the S column stays at the left side when changing its format to duration. Keep in mind, I have selected the S column (except from the Official Time row), and then selected Format > Numbers > Duration. Here is a screenshot: http://prntscr.com/oegu7s

It seems to me that I have done it correctly, however my stubborn sheet does not want to change its format.

Thanks for the help, anyway.

Got the same error in the LibreOffice Calc. The format options doesn't work. Treehouse is FULL of examples that didn't work. That's enough for me. Not renewing my sub after that.

I have the same problem. I get 0.00.00 in the column. The problem is that the column has the values in this format: 6:05:51, and when you select "Duration" Google expects this format: 6.05.51.

I have not found a way to fix this yet though. Have been trying to change to a custom format, but no luck yet.