Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Game Development How to Make a Video Game Game Audio Script a Random Sound Player

Leo Seabra
Leo Seabra
449 Points

MonoDevelop won't open!

I double click on my RandomSoundPlayer script, yet it opens Visual Studio instead of MonoDevelop! And I can't remember my Microsoft account so I cant use it.

open up Unity preferences -> external tools -> change the script editor from Visual Studio to MonoDevelop.

hope that helps!

1 Answer

Alan Mattan贸
Alan Mattan贸
Courses Plus Student 12,188 Points

Probably you are using the latest version of Unity5 or 2017. Same courses are made in Unity 4 or Unity5.1 that includes MonoDevelop. If you are using a new version of Unity, it can open both, Mono and Visual Studio. I strongly suggest to use both and decide what are you more comfortable with.

Your Microsoft one universal password for all the product: Microsoft Account includes Skype, Outlook.com, OneDrive, Windows Phone, Xbox LIVE, Visual Studio... So for resetting the password go to https://account.live.com/ResetPassword.aspx

If you want to return back to MonoDevelop, be sure that Mono is installed. Then you need to go to Unity, click on Edit --> Preferences and then select external tools you can change it to MonoDev. Probably you need to restart Unity. http://answers.unity3d.com/questions/919467/no-monodevelop-for-unity-5.html