Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Design Mobile Game Design Animating and Saving Sprites Exporting Assets

multiartboards js not working

the multi-artboards js file is not working on my AI. is there a reason why? i am totally lost with it

Jake Fleming
Jake Fleming
Treehouse Guest Teacher

Kelvin, could you describe to me which version of AI you are using as well as the steps you are taking when trying to use the file?

hi Jake, l have got C6. the steps i followed is just as in video.

Jake Fleming
Jake Fleming
Treehouse Guest Teacher

In what step does it fail? Can you get to the "Export Arboards" window when opening the script? Is it failing after you hit export? I need a little bit more info before I can pinpoint exactly what is going wrong.

it all works out just as in the video the arts get selected and am able to put in @2x and 200% but after hitting export and going into my sprites folder they would be nothing there.

Jake Fleming
Jake Fleming
Treehouse Guest Teacher

Did you make sure to choose the right output directory? Use the "Choose" button in the Export window for the output directory and navigate to the correct folder where you would like your sprites to be saved. Then try exporting again.

l have just tried that but says at the bottom exporting 0 out of 3 artboards

1 Answer

Jake Fleming
STAFF
Jake Fleming
Treehouse Guest Teacher

OK, Kelvin. I think i know what the issue is. You need to name EACH artboard in order for them to be recognized by the script as exportable. So hit "shift + O" on your keyboard and then up in the top app bar where it says "Name", that's where you can rename your artboards. Then try exporting again. It should work.

that worked thanks