Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS CSS Selectors Going Further with Attribute Selectors and Pseudo-Classes Substring Matching Attribute Selectors - "Begins With" and "Ends With"

My icons are not working

In this vidio I am doing everything right but the icon is not coming out. What am I doing wrong? Here is my code: /* Base Styles -------------------------------- / body { font-family: 'Nunito', sans-serif; line-height: 1.5; color: #384047; padding: 10px 0 80px; } div { max-width: 610px; margin: auto; } ul { list-style: none; padding: 0; } li { margin-bottom: 14px; } a { color: #4183c4; } / Substring Matching Attribute Selectors ---- */ a[href^="http:"] { color: #52bab3; text-decoration:none; background-repeat: no-repeat; background-size: 18px 18px; padding-left: 25px; }

a[href=$".pdf"] { background-image: url(../img/icn-pdf.svg); }

a[href=$".jpg"] { background-image: url(../img/icn-picture.svg); }

a[href=$".zip"] { background-image: url(../img/icn-zip.svg); }

1 Answer

You have

href=$

instead of

href$=

in your icon selectors

Thank you