Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Installing Rails on Mac

8,027 Points

Need help to install ruby on my mac : no route to host?? :(

Hello, i've got an error while trying to install RVM. No route to host while trying to install RVM

With the first command line : gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3

Please, can someone help?

6 Answers

8,027 Points

Please, can someone help me. I can't continue to learn...

Jay McGavren
Jay McGavren
Treehouse Teacher

"No route to host" means that your computer can't find a route across the internet to connect to the host, keys.gnupg.net. This could be due to a variety of reasons:

  • There is something wrong with your computer's internet connection. Try rebooting.
  • Your network is interfering with this type of connection (very possible if you are connecting from an office or school). Try connecting using a different wifi network if possible.
  • There was something wrong with the keys.gnupg.net host at the time you ran this command. Now that a day has passed, try the same command again and see if your connection is successful.

If it still doesn't work, please try running the command:

ping keys.gnupg.net

And then copy and paste the output you get into a comment on this forum thread. You should see something like this:

$ ping keys.gnupg.net
PING pool.sks-keyservers.net ( 56 data bytes
64 bytes from icmp_seq=0 ttl=52 time=145.074 ms
64 bytes from icmp_seq=1 ttl=52 time=144.807 ms
8,027 Points

Hello, thanks so much. I tried everything but it didn't work.

Here is the output for the command ping keys.gnupg.net

Theo$ ping keys.gnupg.net
PING pool.sks-keyservers.net ( 56 data bytes
64 bytes from icmp_seq=0 ttl=48 time=43.122 ms
64 bytes from icmp_seq=1 ttl=48 time=42.389 ms
64 bytes from icmp_seq=2 ttl=48 time=41.361 ms
64 bytes from icmp_seq=3 ttl=48 time=41.655 ms
64 bytes from icmp_seq=4 ttl=48 time=41.960 ms
64 bytes from icmp_seq=5 ttl=48 time=43.752 ms
64 bytes from icmp_seq=6 ttl=48 time=42.486 ms
64 bytes from icmp_seq=7 ttl=48 time=41.520 ms
64 bytes from icmp_seq=8 ttl=48 time=46.303 ms
64 bytes from icmp_seq=9 ttl=48 time=42.298 ms
64 bytes from icmp_seq=10 ttl=48 time=42.013 ms
64 bytes from icmp_seq=11 ttl=48 time=44.783 ms
64 bytes from icmp_seq=12 ttl=48 time=41.000 ms
64 bytes from icmp_seq=13 ttl=48 time=41.557 ms
64 bytes from icmp_seq=14 ttl=48 time=43.285 ms
64 bytes from icmp_seq=15 ttl=48 time=41.417 ms
64 bytes from icmp_seq=16 ttl=48 time=41.492 ms
64 bytes from icmp_seq=17 ttl=48 time=42.317 ms
64 bytes from icmp_seq=18 ttl=48 time=42.335 ms
64 bytes from icmp_seq=19 ttl=48 time=41.067 ms
64 bytes from icmp_seq=20 ttl=48 time=41.382 ms
64 bytes from icmp_seq=21 ttl=48 time=41.500 ms
64 bytes from icmp_seq=22 ttl=48 time=41.790 ms
64 bytes from icmp_seq=23 ttl=48 time=42.159 ms
64 bytes from icmp_seq=24 ttl=48 time=43.010 ms
64 bytes from icmp_seq=25 ttl=48 time=42.790 ms
64 bytes from icmp_seq=26 ttl=48 time=43.682 ms
64 bytes from icmp_seq=27 ttl=48 time=41.717 ms
Request timeout for icmp_seq 28
64 bytes from icmp_seq=29 ttl=48 time=40.950 ms
64 bytes from icmp_seq=30 ttl=48 time=41.126 ms
64 bytes from icmp_seq=31 ttl=48 time=41.411 ms

and so on...

Jay McGavren
Jay McGavren
Treehouse Teacher

https://rvm.io/rvm/security says:

In rare cases the gpg --keyserver is failing, use this instead:

curl -sSL https://rvm.io/mpapis.asc | gpg --import -

Can you copy and paste that command into your terminal? If it doesn't work, can you copy and paste the command and its output into another reply here?

Also, what version of Mac OS are you running? If it's very old then it might be missing some of the root certificates needed to establish secure connections to these servers.

8,027 Points
MacBook-Pro-de-Theo-2:~ Theo$ curl -sSL https://rvm.io/mpapis.asc | gpg --import -
gpg: /Users/Theo/.gnupg/trustdb.gpg : base de confiance créée
gpg: clef 3804BB82D39DC0E3 : clef publique « Michal Papis (RVM signing) <mpapis@gmail.com> » importée
gpg:       Quantité totale traitée : 1
gpg:                     importées : 1
gpg: aucune clef de confiance ultime n'a été trouvée
MacBook-Pro-de-Theo-2:~ Theo$ 

Thats in French, but it says public key import total quantity : 1 imported : 1 no ultimate confidence key find

i'm currently running the last version of OS X on the last macbook pro model.

thanks for the help

Jay McGavren
Jay McGavren
Treehouse Teacher

OK, good, that should mean that it worked. Now try following all the remaining commands in the tutorial, starting with this:

\curl -sSL https://get.rvm.io | bash -s stable

If anything doesn't work, just copy and paste the output here.

Tobias Jackson
Tobias Jackson
9,758 Points

tobiass-MacBook-Pro-3:~ tobiasjackson$ \curl -sSL https://get.rvm.io | bash -s stable Downloading https://github.com/rvm/rvm/archive/1.29.1.tar.gz Downloading https://github.com/rvm/rvm/releases/download/1.29.1/1.29.1.tar.gz.asc gpg: Underskrift lavet Søn 19 Feb 21:02:47 2017 CET gpg: bruger RSA nøgle 62C9E5F4DA300D94AC36166BE206C29FBF04FF17 gpg: God underskrift fra »Michal Papis (RVM signing) mpapis@gmail.com« [ukendt] gpg: også kendt som »Michal Papis michal.papis@toptal.com« [ukendt] gpg: også kendt som »[jpeg image of size 5015]« [ukendt] gpg: ADVARSEL: Denne nøgle er ikke certificeret med en troværdig underskrift! gpg: Intet tyder på at denne signatur tilhører ejeren. Primær nøglefingeraftryk: 409B 6B17 96C2 7546 2A17 0311 3804 BB82 D39D C0E3 Undernøglefingeraftryk: 62C9 E5F4 DA30 0D94 AC36 166B E206 C29F BF04 FF17 GPG verified '/Users/tobiasjackson/.rvm/archives/rvm-1.29.1.tgz'

Upgrading the RVM installation in /Users/tobiasjackson/.rvm/ RVM PATH line found in /Users/tobiasjackson/.mkshrc /Users/tobiasjackson/.profile /Users/tobiasjackson/.bashrc /Users/tobiasjackson/.zshrc. RVM sourcing line found in /Users/tobiasjackson/.profile /Users/tobiasjackson/.bash_profile /Users/tobiasjackson/.zlogin. Upgrade of RVM in /Users/tobiasjackson/.rvm/ is complete.

Tobias Jackson,

Thank you for using RVM!

We sincerely hope that RVM helps to make your life easier and more enjoyable!!!

~Wayne, Michal & team.

In case of problems: https://rvm.io/help and https://twitter.com/rvm_io

Upgrade Notes:

  • WARNING: You have '~/.profile' file, you might want to load it, to do that add the following line to '/Users/tobiasjackson/.bash_profile':

    source ~/.profile

  • No new notes to display.

tobiass-MacBook-Pro-3:~ tobiasjackson$