Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Development Tools Installing a Ruby Development Environment Installing a Ruby Development Environment Installing the Treehouse VM on Windows

1,795 Points


I run exactly same as video 1-rails new testapp 2-bin folder of testapp 3-rails server

Ī» rails server => Booting WEBrick => Rails 4.1.8 application starting in development on => Run rails server -h for more startup options => Notice: server is listening on all interfaces ( Consider using (--binding option) => Ctrl-C to shutdown server [2014-12-20 19:28:11] INFO WEBrick 1.3.1 [2014-12-20 19:28:11] INFO ruby 2.1.5 (2014-11-13) [i386-mingw32] [2014-12-20 19:28:11] INFO WEBrick::HTTPServer#start: pid=7180 port=3000

But when I try to deploy on Chrome/IE with http//localhost:3000

This webpage is not available I tried in IE as well - home page not displayed....

3 Answers

Based on your post, you have the url slightly wrong. You're missing the colon after http. It should be:


1,795 Points

Thanks, Imouto. I tried with the same url. Url is correct. While posting here, typing mistake. Even reverified. But the same not able to deploy......

I'm not familiar with using Rails in a Windows environment, but judging from your post it sounds like you're able to run the Rails server just fine. With the Rails server running, when you try to view http://localhost:3000 in any browser what messages do you see in the Cmder window (or whatever console you're using)?

Not sure if you'll want to do this, but I just read this forum thread that mentions that Treehouse's Workspaces supports Rails. Here's the forum thread if you haven't seen it: