Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (2014) Getting Started with Android Setting Up an Android Development Environment for Windows

Tejaswi Kulkarni
Tejaswi Kulkarni
1,875 Points

Not able to open android studio

After the installation of JAVA and Android Studio....I tried to open the android studio but, it tells me to define the JAVA_HOME variable in Computer>System Properties>System Settings>Environment Variable...! What do I do?

I had already added JAVA_HOME and it still gave this error. When I added C:\Program Files\Java\jdk1.7.0_67\jre\bin to the PATH, Android Studio found what it needed and started up.

1 Answer

This is a setting you set in windows.
For windows 7(pretty much same after vista)

goto your control panel
click "system"
click "advanced system settings"
click "advanced" tab
click "environment variables"
in the bottom section "system variables"
click "new"
Variable name: "JAVA_HOME" (no quotes)
Variable value: (put in the path to your current version of java)
IE:"C:\Program Files (x86)\Java\jre1.8.0_31\bin"