Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Java Spring Basics Spring Components and Configuring Our App Configuring Gradle for Spring Development

Not working on Gradle 4.4

I have this code in the build.gradle, and sync fails:

plugins { id 'java' id 'idea' id 'eclipse' id "org.springframework.boot" version "2.0.3.RELEASE" }

group 'com.berenguerIV' version '1.0-SNAPSHOT'

sourceCompatibility = 1.8

repositories { mavenCentral() }

dependencies { compile 'org.springframework.boot:spring-boot-starter-web' }

Any ideas why this might fail?

1 Answer

Gergely Horvath
PLUS
Gergely Horvath
Courses Plus Student 8,207 Points

Without any given errror messages it is hard to guess, but you might want to stick to groovy syntax and respect newlines:

plugins {
    id 'java'
    id 'idea'
    id 'eclipse'
    id "org.springframework.boot" version "2.0.3.RELEASE"
}

group 'com.berenguerIV'
version '1.0-SNAPSHOT'

sourceCompatibility = 1.8

repositories {
    mavenCentral()
}

dependencies {
    compile 'org.springframework.boot:spring-boot-starter-web'
}

This one builds for me.

MANOJ KUMAR YADAV
MANOJ KUMAR YADAV
3,507 Points

Also, check if you using a different version of java.

For me, I used below syntax for Java 10 and it worked me

//------------------------------------------------------------------------------------------------------------------------

plugins { id 'java' id 'idea' id 'eclipse' id 'org.springframework.boot' version '1.4.3.RELEASE' }

group 'com.teamtreehouse' version '1.0-SNAPSHOT'

sourceCompatibility = 1.10

repositories { mavenCentral() }

dependencies { // https://mvnrepository.com/artifact/org.springframework.boot/spring-boot-starter-web compile group: 'org.springframework.boot', name: 'spring-boot-starter-web', version: '2.0.5.RELEASE'

} //--------------------------------------------------------------------------------------------------------------------------------

Stefan Novak
Stefan Novak
6,791 Points

Thank you. This worked as of 06/04/2019.

It's a shame though, looks like this course is going to be full of these issues.