Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

JavaScript JavaScript Loops, Arrays and Objects Simplify Repetitive Tasks with Loops A Closer Look at Loop Conditions

Gavin Hughes
Gavin Hughes
6,487 Points

Nothing displayed

I suspect there is a typo or I've missed something somewhere but I can't seem to find it so nothing is displaying on the page currently.

var upper = 1000;
var randomNumber = getRandomNumber( upper );
var guess;
var attempts = 0;

function getRandomNumber(upper) {
  return Math.floor( Math.random() * upper ) + 1;

while ( guess !== randomNumber ) {
  guess = getRandomNumber( upper );
  attempts +=1;
document.write("<p>The random number was: " + randomNumber + "<p>");
document.write("<p>It took the computer " + attempts + " attempts to guess the random number.</p>");
Mark Miller
Mark Miller
45,831 Points

It looks like you need to type the slash in the tag ending the paragraph.

3 Answers

Jennifer Nordell
Jennifer Nordell
Treehouse Teacher

I don't really know what to tell you except maybe refresh the page and possibly clear your browser cache? When I run your code in the console... this is the output.

The random number was: 967

It took the computer 1696 attempts to guess the random number.

No errors detected by the developer tools :)

But Mark is correct... you're missing a backslash in the closing paragraph tag in the first paragraph.

Gavin Hughes
Gavin Hughes
6,487 Points

I spotted the missing backslash and fixed that. Also tried printing the outputs to but nothing showed.

Clearing browser cache has got it working though!

Thank you both for your quick replies.

There's an error in Dave's code that he displays in the video. His code is missing the backslash for the first paragraph tag. This error can be seen at 06:17 min into the video. That's potentially why Gavin is missing the first backslash. He (and I) were following along with the code as displayed by Dave.