Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Java

Oh no! We encountered an error with your last submission.

I have added the code for the todo section within Main.java. My project builds just fine, the tests run/pass, if I run main and compare the output from imperative vs declarative they match, but when I upload the zip file I get an error after it runs the tests that is "Oh no! We encountered an error with your last submission." I am unsure how to troubleshoot this when there is no other information in the error provided and everything works within IntelliJ. Any insight would be great.

Here is what I added

    scores.stream()
      .filter(score-> score.getGame().equals("Burger Time"))
      .filter(score -> score.getAmount() >= 20000)
      .forEach(System.out::println);

Not sure if anyone else has run into this issue recently.

I still have not been able to submit any of the code challenges from the Intro to Functional Programming course.

I inspected the network calls to see if that would give me any more indication as to what was failing but they all came back as successful calls. I've uninstalled and reinstalled IntelliJ, tried submitting in multiple browsers, tried different jdks and gradle versions, turned off my personal DNS routing that was blocking ads - none of which worked.

I reached out to support and they were able to submit on their side. I'm wondering if there is a specific Java or Gradle version I need to be using or if it could be something to do with the version of IntelliJ I'm using(IntelliJ Community Edition 2020.3).

Any insight would be appreciated. Thanks!