Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

APIs Build a Chatbot with Watson APIs Introducing the Watson APIs Starting Our Local Client

Beau Genereux
Beau Genereux
5,362 Points

Outdated course — any updates on the roadmap?

I am finding this course very difficult to follow. A lot has changed since it was created.

The installation of the project demo returns so many errors, I wonder if it is even worth it for me to try to debug them — I know I'm very new to coding but this seems "serious" ?

~/c/t/watson_chatbot ❯❯❯ npm install
npm WARN deprecated cloudant@1.4.1: This package is now scoped. The new name is @cloudant/cloudant
npm WARN deprecated to-iso-string@0.0.2: to-iso-string has been deprecated, use @segment/to-iso-string instead.
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated request@2.55.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated hawk@2.3.1: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated mkdirp@0.3.0: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm WARN deprecated har-validator@1.8.0: this library is no longer supported
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.

> execSync@1.0.2 install /Users/beau/code/treehouse/watson_chatbot/node_modules/execSync
> node install.js

[execsync v1.0.2] Attempting to compile native extensions.
[execSync v1.0.2]
    Native code compile failed!!

> websocket@1.0.24 install /Users/beau/code/treehouse/watson_chatbot/node_modules/websocket
> (node-gyp rebuild 2> builderror.log) || (exit 0)

  CXX(target) Release/obj.target/bufferutil/src/bufferutil.o

> core-js@2.6.11 postinstall /Users/beau/code/treehouse/watson_chatbot/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm WARN notsup Unsupported engine for follow@0.12.1: wanted: {"node":"0.12.x || 0.10.x || 0.8.x"} (current: {"node":"12.18.2","npm":"6.14.5"})
npm WARN notsup Not compatible with your version of node/npm: follow@0.12.1
npm WARN watson_chatbot@0.1.1 No repository field.

added 472 packages from 708 contributors and audited 472 packages in 29.355s

1 package is looking for funding
  run `npm fund` for details

found 135 vulnerabilities (34 low, 52 moderate, 47 high, 2 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

The npm audit fix returned the following:

~/c/t/watson_chatbot ❯❯❯ npm audit fix                                                                               ✘ 1 
npm WARN deprecated mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm WARN watson_chatbot@0.1.1 No repository field.

+ body-parser@1.19.0
+ express@4.17.1
added 16 packages from 12 contributors, removed 15 packages and updated 26 packages in 6.239s

1 package is looking for funding
  run `npm fund` for details

fixed 58 of 135 vulnerabilities in 472 scanned packages
  67 vulnerabilities required manual review and could not be updated
  3 package updates for 10 vulnerabilities involved breaking changes
  (use `npm audit fix --force` to install breaking changes; or refer to `npm audit` for steps to fix these manually)

I'm currently updating my OS to Catalina because it seems like I cannot follow the IBM Watson tutorials without the cf CLI and my current Xcode won't update ¯_(ツ)_/¯

  • A sad but not completely discouraged student o_O