Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial



i've installed and uninstalled and extracted the damn dev files cmd prompt says:

'ruby' is not recognized as an internal or external command, operable program or batch file.

windows 7 32 bit

i downloaded rubyinstall 2.0.0-p451 and the devkit to go with it....

path C:\Ruby200\bin;C:\Users\Alvin\AppData\Roaming\npm

system variables C:\Ruby200\bin;C:\Ruby200\bin\;C:\Program Files\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\nodejs\;C:\Program Files\Git\cmd;C:\Program Files\Git\bin

been watching that video in the ruby's track

and ruby -v says the "ruby is not recognized as an internal" message....

Treehouse support has said to post this on the forum... This is my 3rd post for this problem... even after looking this problem up in google, I have yet to find a solution.... I've been trying to install this thing for over 8 hours...

2 Answers

Kang-Kyu Lee
Kang-Kyu Lee
52,045 Points

Hi Alvin as for me I ended up following virtual machine video instead at the time, and for now I bought this apple.. I recommend install ubuntu also - But, you may still try and make sure to

  1. uninstall ruby completely
  2. run rubyinstaller (Ruby 1.9.3-p545 file)

Ruby should be installed without any other installation in the video. Hope good luck

I've tried your method of installing the older version of 1.9.3... now it says it seems your ruby installation is missing psych.... i've tried to download YAML and put it in the same directory... and to no avail... any ideas?

Tony McKeown
Tony McKeown
Courses Plus Student 14,300 Points

Did you try following the advice about the path in your last post? https://teamtreehouse.com/forum/cant-install-ruby

I don't use Ruby on Windows but from googling that seems to be the most common reason for that eror.

Another use with a similar problem on stackflow that seemed to work after restarting.


I've checked my first post... it didnt work... i've already done the 2nd thing you suggest from a youtube video... and the person who put up the video cant seem to figure it out either after i've posted everything to him...