Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Build a JavaFX Application Build a Pomodoro App Explore Existing Code

Rokas Mazeika
Rokas Mazeika
4,243 Points

Plz help i have this problem with every fxml application plz someone answer

Please someone please

Exception in Application start method
Exception in thread "main" java.lang.RuntimeException: Exception in Application start method
    at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:917)
    at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$155(LauncherImpl.java:182)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
    at com.teamtreehouse.pomodoro.Main.start(Main.java:15)
    at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$162(LauncherImpl.java:863)
    at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$175(PlatformImpl.java:326)
    at com.sun.javafx.application.PlatformImpl.lambda$null$173(PlatformImpl.java:295)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(PlatformImpl.java:294)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
    at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    at com.sun.glass.ui.win.WinApplication.lambda$null$148(WinApplication.java:191)
    ... 1 more

Process finished with exit code 1

this is my error i ran the video code

3 Answers

6,387 Points

Without seeing your code all I can tel is you have a null pointer exception. You may have not assigned or imported something post your code and I'll have a gander.

Sorry for any spelling mistakes on my phone

Rokas Mazeika
Rokas Mazeika
4,243 Points

There are the same as the video's

6,387 Points

You may have made a mistake that you didn't notice. Which is why i'm asking you to paste your code :)

Ryan Lentz
Ryan Lentz
9,191 Points

I had the same problem. Here is what worked for me:

  1. Create Pomodoro as a new project.
  2. Open the s3v1 folder and copy all of its contents.
  3. Find the Pomodoro folder using your the File Explorer on your computer.
  4. Delete all of the contents of the Pomodoro folder and replace them with the contents that you copied from the s3v1 folder.

You should be good to go.