Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS iOS Tools CocoaPods CocoaPods

Lauren Washington
Lauren Washington
1,533 Points

Pod install error in terminal: not creating xcode workspace

I'm in the Photo Bombers course and moved to the Cocoapods course mid-way, but have been stuck for hours trying to figure out why it won't create a workspace for me. I've tried uninstalling and reinstalling Xcode, Ruby, Cocoapods. I've deleted and started the project again. I've even tried to install the pod through xcode or directly through the terminal as some people in the forum suggest. Nothing is working- please help!

I have Xcode 6.0.1 and Mac OSX Mavericks and am getting the following from my terminal when I try "pod install":

Last login: Sun Nov 30 20:04:56 on ttys000
Lauren-Washington-MacBook-Air-55:~ lwashington$ cd /Users/lwashington/Documents/Development/CocoaExample 
Lauren-Washington-MacBook-Air-55:CocoaExample lwashington$ pod install

Analyzing dependencies

/Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/2.1.0/pathname.rb:425:in `open': No such file or directory @ dir_initialize - /Users/lwashington/.cocoapods/repos (Errno::ENOENT)
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/2.1.0/pathname.rb:425:in `foreach'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/2.1.0/pathname.rb:425:in `children'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/lib/cocoapods/sources_manager.rb:63:in `all'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/lib/cocoapods/user_interface/error_report.rb:130:in `repo_information'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/lib/cocoapods/user_interface/error_report.rb:34:in `report'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/lib/cocoapods/command.rb:58:in `report_error'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/claide-0.7.0/lib/claide/command.rb:300:in `handle_exception'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/claide-0.7.0/lib/claide/command.rb:274:in `rescue in run'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/claide-0.7.0/lib/claide/command.rb:264:in `run'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/lib/cocoapods/command.rb:45:in `run'
    from /Users/lwashington/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/cocoapods-0.35.0/bin/pod:43:in `<top (required)>'
    from /Users/lwashington/.rbenv/versions/2.1.3/bin/pod:23:in `load'
    from /Users/lwashington/.rbenv/versions/2.1.3/bin/pod:23:in `<main>'
Lauren-Washington-MacBook-Air-55:CocoaExample lwashington$

1 Answer

Pasan Premaratne
Pasan Premaratne
Treehouse Teacher

Hey Lauren Washington,

Try this first (you might have already) - Run:

pod setup
pod install 

If that doesn't work, try removing the cocoapods directory ~/.cocoapods and running pod setup and install again.

rm -rf ~/.cocoapods 
pod setup
pod install

If that doesn't work either, remove the cocoapods directory again and manually clone the specs repo into ~/.cocoapods/repos/master and run pod install

rm -rf ~/.cocoapods 
git clone https://github.com/CocoaPods/Specs.git ~/.cocoapods/repos/master
pod install

Let me know if that works!!

Lauren Washington
Lauren Washington
1,533 Points

Thank you so much!! The first one (pod setup, pod install) worked. You are a lifesaver!