Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Problem started with debugger, but now also when running Stormy app

My issue first started with the debugger. I ran it the first time and it was fine. Then, when I ran it again it wouldn't work. Android Studio gave the message

Connected to the target VM, address: 'localhost:8600', transport: 'socket'

I checked the forums and stack overflow but none of the suggestions worked for me.

Now, when I try to run the app in an emulator or on my device it doesn't display any data. Logcat shows that the data is coming through but the app doesn't show the weather forecast any more.

Please someone help me. I'm close to throwing my laptop out of the window.

1 Answer

Weather forecasting app, right? If you throw your laptop out of the window and it is wet when you get it back, it's raining. ;-)

It might be best to post your code in here - or if you upload it into Github or BitBucket, I can pull the code down and replicate the issue here.


Oh man, I didn't want to write this. Its really embarrassing. The debug wasn't working because I put the breakpoint in the wrong place, and the app wasn't working because of a spelling mistake.

I tried to get the app onto github so you could look at it but I messed that up too.

Thank you for offering help.

Hey - don't worry about it! I've made all those errors, and more - they're the best way to learn.

Key thing is that you spotted the issues!

Keep it up!