Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS

Problem with Code Challenge Engine

Hello, I am currently working on the "Create a NSString variable named 'myString' with the value 'Fun with Objective-C'." lesson. When I write out the string in the given blank and click "Check Work" I get an error message stating "There was a problem connecting to the Code Challenge Engine: Timeout Error."

Has anyone else experienced this problem?

6 Answers

Jorge Cruz
Jorge Cruz
19,305 Points

Yes, All the iOS code challenges I tried in the introduction course have the same error. I already submitted a ticket to support. Hopefully, they fix it quick.

Amit Bijlani
STAFF
Amit Bijlani
Treehouse Guest Teacher

We are sorry about the problems with the code challenge engine. We are looking into it and will have it running as soon as we can.

You think they would have sorted this by now, frustrating when you want to move on!

Chris Jones
Chris Jones
9,419 Points

I'm having the same issue, but the code challenges are optional, so you can progress through the courses without having to pass the code challenges, not brilliant if your not able to work on it alongside (I have a mac fortunately) so I've just been skipping the code challenges thus far, hope to go back and complete them once the issue is sorted

I've had the same issue but it seems as though I have it only from my home internet connection. At work I've never got that error, but as soon as I start working from home it pops up intermittently. I've found that a refresh of the page typically seems to clear it, but you lose the work you've done and have to start from step 1 again. (so remember to copy and paste)

Bottom line, I don't think it is a treehouse issue.