Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript Building a MEAN Application Introduction to the MEAN Stack Building a MEAN App Overview

Problem with yo and meanjs

5 Answers

Did you make sure to follow the instructions first?

First, you should run npm install -g yo, in order to install Yeoman.

Then, you should install the mean.js generator:
npm install -g generator-meanjs

After that, you should then be able to do yo meanjs successfully.

It also seems that your package name included a period (.) inside of it. I believe the package name is just meanjs. I just tried all of this on my machine and it worked successfully, but let me know if you get stuck elsewhere.

John Halbert that solved it. You know why this happens and how to fix it? Thanks for looking: http://stackoverflow.com/questions/35981585/npm-err-enoent-and-is-related-to-npm-not-being-able-to-find-a-file

I think this could be why the videos are building the todo app from scratch rather than using yo...I don't plan on downgrading node, too many other things rely on the latest version.

Mona Jalal James Fehr There are a lot of packages that require a lower version of node to be installed. A recent occurrence of this I've faced is installing the Foundation CLI installer where libsass was giving me trouble. A solution was to downgrade, but as James mentioned previously, it's a bit of a hassle.

Luckily, I found a solution. nvm is available, and allows you to switch which version of node you're using by using a simple nvm use [version] command. Although that specific project is Unix-based, there is a Windows version available here

Funny that you mention that, I was wondering why it didn't throw an error in install, glad to see a package I use to protect other builds is working on this one.