Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Jessica Barnett
Jessica Barnett
8,028 Points

Problems starting the AVD in Eclipse

Hello All!

I'm having some trouble getting the AVD to start up for the first time in Eclipse.

When I hit start in the AVD manager, I get to the "starting android emulator" dialog with the progress bar. It completes, closes, and then nothing happens. No error messages. Just crickets.

I tried right clicking on the xml document > run as > android application. It didn't work, but I did get some red error messages:

[2014-04-30 18:54:03 - DiscoBall] The connection to adb is down, and a severe error has occured. [2014-04-30 18:54:03 - DiscoBall] You must restart adb and Eclipse. [2014-04-30 18:54:03 - DiscoBall] Please ensure that adb is correctly located at '/Users/Jessica/Desktop/android_dev_environment_mac/sdk/platform-tools/adb' and can be executed.

At this point I'm thinking maybe there's a problem with whatever the initial_setup file was doing. So I moved the whole folder, re-ran initial_setup, and restarted eclipse. This time I got this in the console as soon as I started a new Project:

[2014-04-30 19:17:24 - DeviceMonitor] Connection attempts: 1

Tried to run the ADV. Same Result. Tried rightclick > run as > android app again too. No error messages this time but it still didn't do anything.

In the AVD manager I changed the ram of the device to 1024, 512, and 256, with and without the host gpu. So that's not it...

At the bottom, there's a little progress bar, the SDK content loader. It always looks like it's still loading and re-loading the same 233MB. Not sure if that has to do with anything, but it's suspicious. I'm running Mac OS10.6.8

Lots of details I know. But hopefully some of them are relevant. Anybody have any ideas? It's probably something obvious...

Thank you!

2 Answers

Masum Bergmann
PLUS
Masum Bergmann
Courses Plus Student 4,129 Points

Hi Jessica, I've never come across the problem that you describe in your post, so I can't really offer a direct fix (sorry), but... have you tried using an emulator from Genymotion? (http://www.genymotion.com/) You'll be up and running in a couple of minutes... (bonus: Genymotion emulators load much faster, and are more responsive)... Best, Masum

Masum Bergmann
Masum Bergmann
Courses Plus Student 4,129 Points

Hi Jessica, just found out yesterday that the Genymotion emulator does have a tiny drawback: Emulator Control in the DDMS is disabled. No biggie (I guess), but just thought you should know!