Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML Introduction to HTML and CSS Adding a New Web Page Write the HTML

Cameron Scully
Cameron Scully
2,919 Points

Question about typing the code settings

When writing my code, how do I set my settings so, like in the video, I can type <h1> and have </h1> come up automatically and be able to continue to type without deleting the </h1> the program just made for me.

for example i just typed "<h1>"

''' <h1></h1> '''

then immediately after the system gave me a </h1>

how do i write my code so when i type while these two are generated the brackets will ove with my typing so this doesn't happen, for example.

has been happening (below) i begin to type "he"

''' <h1>he1h> '''

want to happen (below) i just typed "he"

''' <h1>he</h1> '''

Calin Bogdan
Calin Bogdan
14,921 Points


Are you talking about Workspaces or a particular text editor you are using? If you're using a text editor (Atom, Visual Studio Code, etc.) you can install plugins that do such things (and many more!).

Cameron Scully
Cameron Scully
2,919 Points

I am specifically talking about Workspaces for this example, but if you know the term that applies to the setting I am trying to address I would appreciate it :)

1 Answer

Jennifer Nordell
Jennifer Nordell
Treehouse Teacher

Hi there! I believe the insertion method of typing is incorrect. Try hitting the "Insert" button exactly once (it's a toggle) and try this again. When I try it in workspaces, if I toggle it to the other setting I experience what you are experiencing where it writes over what is already written there. When I hit the "Insert" key once, it stops this behavior.

Hope this helps! :sparkles: