Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Questions on Launching Website

All the tutorials have been great so far, but I was hoping you could expand on the uploading content stage. Getting a domain name, server space (used Dreamhost like you showed), and accessing the sftp server through Cyberduck was fairly straightforward but simply dragging and dropping the files we worked on has not seemed to work for me.

First off, the sftp already had 3 directories in it when I got to it - logs, maildir, and (the domain name).com. First, I dragged and dropped the files like you showed but the site just displayed dreamhost's same default content when I viewed it.

Next I tried deleting all the folders that were in there and then loading my content. This resulted in 403 permission error so I put it all back in there but the error still didnt go away. The folks at Dreamhost changed the permissions (I think just back to what they were before) but I still haven't wrapped my head around how to fix it if it happens again.

Finally, I started getting somewhere by deleting the content out of '(the domain name).com' folder and replacing it with my files but when I open it in the browser (safari and chrome) it does not show up like if does when I open it from my computer. After looking at it with the developer tool on safari, the normalize.css and grid.css files are showing up red so I'm guessing they are having trouble being referenced, do you know what might be causing this? I have tried it with my file as well as with the final project files folder download and neither have worked.

5 Answers

jeff creamer
jeff creamer
23,733 Points

Hey Wylie, check out your lines 6-7 of your html doc. You've started a comment <!--, then added another opening angled-bracket <, then closed the broken comment after the next line. Looks like if you remove that stuff the stylesheets for grid and normalize should be referenced.

James Barnett
James Barnett
39,199 Points

You need to make sure the permissions on your grid.css & normalize.css files are the same as your style.css file.

To do this in cyberduck:

  • Connect to your hosting account using Cyberduck via SFTP
  • Select the normalize.css & style.css files
  • Select the Info button
  • Select the Permissions button
  • In the text box beside UNIX Permissions enter 644 Cyberduck permissions
  • Click the red circle to close the permissions window
  • You're done :)

What's the link to the website?

Thanks for catching that part, I forgot to mention that detail.

Another way i had tested it was by turning that what I had written (lines 6-7) in to a comment and then copy/pasting the corresponding lines from the downloaded project file (see lines 8-9 on my page) to see if I there was some grammatical error I just was not seeing but it still had the same issue

I really appreciate everyone who's taking the time to look into it though!