Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


David Langley
David Langley
10,965 Points

Rails new treebook Not working on my machine ... a week later still not working...

I have had some issues getting Ruby and Rail installed but thought I was there, apparently not.....

When I type;

rails new treebook

I get;

davids-mbp:treehouse chickenguts$ rails new treebook /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in to_specs': Could not find 'minitest' (~> 4.2) - did find: [minitest-5.3.0,minitest-2.5.1] (Gem::LoadError) from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1268:inblock in activate_dependencies' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1257:in each' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1257:inactivate_dependencies' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1239:in activate' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1271:inblock in activate_dependencies' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1257:in each' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1257:inactivate_dependencies' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:1239:in activate' from /Users/chickenguts/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:48:ingem' from /Users/chickenguts/.rvm/gems/ruby-1.9.3-p484/bin/rails:22:in <main>' from /Users/chickenguts/.rvm/gems/ruby-1.9.3-p484/bin/ruby_executable_hooks:15:ineval' from /Users/chickenguts/.rvm/gems/ruby-1.9.3-p484/bin/ruby_executable_hooks:15:in `<main>'

I admit I am lost with this ......

I reinstalled the bundler thinking it was a problem with Gems... but still get the above when trying to create a new rails project.

what is the easiest was to uninstall everything done in the ruby and rails install so I can try again from scratch ?

Should everything live in the treehouse directory/folder or in the main user directory/folder ?

really bummed this has been going on for almost a week now.....

2 Answers

Ace Motanya
Ace Motanya
31,756 Points

You have some issues with your versions on ruby on you computer. Trying to load some 1.9.1 while working in 1.9.3. I would suggest updating to the latest version. You can go here and it will walk you thru the process. http://www.interworks.com/blogs/ckaukis/2013/03/05/installing-ruby-200-rvm-and-homebrew-mac-os-x-108-mountain-lion

David Langley
David Langley
10,965 Points

Hi Ace,

thanks for your advice I will try anything at this point ! I actually have the most recent version of Ruby 2.1.1 p76 Rails 4.0.3

Appreciate your help.