Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Build a Todo List Application with Rails 4 Build a Todo List Application with Rails 4 Generate a Rails Application

rails s -b 0.0.0.0 works but not bin/rails server??

After creating odot and going through the version video I was not able to access localhost:3000. It said No data Received ERR_EMPTY_RESPONSE when typing

bin/rails server

in terminal. Quick google search and I tried

rails s -b 0.0.0.0

instead and it worked. Is that okay? What could be the problem?

3 Answers

Rachelle Wood
Rachelle Wood
15,361 Points

I can't answer your question fully, but I managed to get it working by going into the bin folder and typing rails server.

if bin/rails server is not working , just put : ruby bin\rails server it should work

'rails s' is working.