Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby ActiveRecord Basics Migrations and Relationships Migrations

Charles-Eric Legras
Charles-Eric Legras
4,917 Points

Rake db:create fails !! Can't go further !!! :@

I followed step by step the video, rake db:create fails... Tried to uninstall ruby and gem, use the same ruby version as in the video, etc etc... even use the TeamTreeHouse projects files and it still doesn't work !!!

GETTING CRAZY !!!!!!!!

Ethan Lowry
Ethan Lowry
Courses Plus Student 7,323 Points

Please post the actual errors etc. you're getting any time you have a problem like this if you want people to be able to help.

Charles-Eric Legras
Charles-Eric Legras
4,917 Points
Charlou:biller Charlou$ rake db:create
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/activesupport-4.0.3/lib/active_support/values/time_zone.rb:282: warning: circular argument reference - now
rake aborted!
dlopen(/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/mysql2-0.3.15/lib/mysql2/mysql2.bundle, 9): Library not loaded: libmysqlclient.18.dylib
  Referenced from: /Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/mysql2-0.3.15/lib/mysql2/mysql2.bundle
  Reason: image not found - /Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/mysql2-0.3.15/lib/mysql2/mysql2.bundle
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/mysql2-0.3.15/lib/mysql2.rb:8:in `require'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/mysql2-0.3.15/lib/mysql2.rb:8:in `<top (required)>'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:76:in `require'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:72:in `each'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:72:in `block in require'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:61:in `each'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler/runtime.rb:61:in `require'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/gems/bundler-1.8.2/lib/bundler.rb:134:in `require'
/Users/Charlou/Downloads/biller/config/application.rb:7:in `<top (required)>'
/Users/Charlou/Downloads/biller/Rakefile:4:in `require'
/Users/Charlou/Downloads/biller/Rakefile:4:in `<top (required)>'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/bin/ruby_executable_hooks:15:in `eval'
/Users/Charlou/.rvm/gems/ruby-2.2.0@global/bin/ruby_executable_hooks:15:in `<main>'
(See full trace by running task with --trace)

using Mac OS 10.10.3 ruby 2.2.0

2 Answers

Charles-Eric Legras
Charles-Eric Legras
4,917 Points
Charlou:biller Charlou$ mysql -uroot
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
Kyle Robertson
Kyle Robertson
31,600 Points

In regards to your second error message, try connecting with

 mysql -u root -p

Does a message asking for your password show up?