Development Tools Installing a Ruby Development Environment Installing a Ruby Development Environment Installing Ruby on Mac

Jason Law
Jason Law
14,768 Points

rbenv install 2.0.0-p353

Hello, I am trying to install ruby on ubuntu. I made it up to the rbenv install 2.0.0-p353 step, but then I get an error that states,

"jason@jason-VirtualBox:/$ rbenv install 2.0.0-p353 Downloading yaml-0.1.6.tar.gz... -> http://dqw8nmjcqpjn7.cloudfront.net/7da6971b4bd08a986dd2a61353bc422362bd0edcc67d7ebaac68c95f74182749 Installing yaml-0.1.6... Installed yaml-0.1.6 to /home/jason/.rbenv/versions/2.0.0-p353

Downloading ruby-2.0.0-p353.tar.gz... -> http://dqw8nmjcqpjn7.cloudfront.net/465afc77d201b5815bb7ce3660a1f5a131f4429a3fa483c126ce66923e4726cc Installing ruby-2.0.0-p353...

BUILD FAILED (Ubuntu 14.04 using ruby-build 20150502)

Inspect or clean up the working tree at /tmp/ruby-build.20150503194015.30145 Results logged to /tmp/ruby-build.20150503194015.30145.log

Last 10 log lines: minitest 4.3.2 psych 2.0.0 rake 0.9.6 rdoc 4.0.0 test-unit 2.0.0.0 The Ruby openssl extension was not compiled. Missing the OpenSSL lib? Configure options used: --prefix=/home/jason/.rbenv/versions/2.0.0-p353 LDFLAGS=-L/home/jason/.rbenv/versions/2.0.0-p353/lib CPPFLAGS=-I/home/jason/.rbenv/versions/2.0.0-p353/include ".

Can you help me figure out why I am getting this error so I can go to the next step? Thanks.

1 Answer

I seem to remember having this problem a while back, and searching on line I found several possible solutions.

The one that I think helped me was this one (on Ubuntu, it's different for Mac and Windows):

sudo apt-get install libssl-dev

If that doesn't fix it, there are several other suggestions in the thread where I found that : https://github.com/sstephenson/ruby-build/issues/377

Hope that helps.

Jason Law
Jason Law
14,768 Points

Thank you. The libsssl-dev install helped.