Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Resolving a conflict between Homebrew, and MacPorts or Fink?

I ran out of workspaces, so I decided to install npm locally using homebrew. However, after getting one error (cannot install node using available compilers), I ran brew install gcc. That took forever, but didn't work because apparently I have either MacPorts or Fink installed.

I am able to make some space in my Workspaces for now, to continue with the lesson but to continue with Homebrew I'm a little unsure since I don't remember installing MacPorts or Fink, so I don't know what they're used for. Has anyone run into this or have any advice?

Here are the errors and the links I got in terminal.

make[2]: *** [configure-stage2-target-libstdc++-v3] Error 1
make[1]: *** [stage2-bubble] Error 2
make: *** [bootstrap] Error 2
Warning: It appears you have MacPorts or Fink installed.
Software installed with other package managers causes known problems for
Homebrew. If a formula fails to build, uninstall MacPorts/Fink and try again.

READ THIS: https://git.io/brew-troubleshooting

These open issues may also help:
`gcc`: Force DWARF-2 Debugging Data under Pre-Mavericks https://github.com/Homebrew/homebrew/pull/46111
freeimage: patches for gcc 5.0 https://github.com/Homebrew/homebrew/pull/44612
yap: don't use GCC 5, which breaks https://github.com/Homebrew/homebrew/pull/45977
gcc can't find compatible ISL https://github.com/Homebrew/homebrew/issues/44444
How Do I Specify and Use Homebrew gcc-4.8 in a Formula Instead of OS X Bundled gcc? https://github.com/Homebrew/homebrew/issues/46169
isl 0.15, cloog 0.18.4, gcc compatibility patch https://github.com/Homebrew/homebrew/pull/44486
gcc causes false alarms in C++ stdlib check https://github.com/Homebrew/homebrew/issues/45218
apple-gcc42 takes priority over modern gcc https://github.com/Homebrew/homebrew/issues/41055
gcc 4.9.2 fails to produce debugging information https://github.com/Homebrew/homebrew/issues/34976
Object files deleted during build of gcc needed by gdb https://github.com/Homebrew/homebrew/issues/35734
MacOS.(gcc|clang|llvm)_version can return nil https://github.com/Homebrew/homebrew/issues/18781