Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS Sass Basics (retired) Getting Started with Sass Installing and Using Sass

Ruby console does not detect changes

Hi there! I have just started learning Sass, and I have already got issues xD I downloaded ruby console, which seems working fine, and I use Notepad++ text editor. I created a simple scss file, opened it in the console ( sass test.scss), without running into problems. When I start watching it, though ( sass --watch . ), the console does not detect changes I make to the scss. I tried to google it, but could not find any helpful answer. P.s. when I close and reopen files (scss and its output css) in the text editor, changes then appear. How can I make it work???

4 Answers

Danielle Hill
Danielle Hill
26,062 Points

I just solved this same problem. I created test.scss on my Desktop and although I was in that directory on the command line my changes were not detected. I tried creating a folder called Sass on my Desktop, changing my directory to that folder and creating a test2.scss file. When I executed the "sass --watch ." command it worked! I can't explain it why it worked (I wish I could), but it's worth a try. Good luck!

I know this is probably NOT the answer but are you saving the files? Are you making changes to the right ones? The reason I am asking this is because I had a very similar thing and was wondering why my changes were not appearing. I forgot to a) save the file but another time I was even in the wrong directory.

Check the small things first is what I'm trying to say...

Hi, thanks for your tip Michael, but still haven' t found the problem...