Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript

Jackie Jen
Jackie Jen
2,723 Points

Running Task on AWS ECS

Hi,

I have search alot from google but can't find any possible solutions. Here is my problem

when i push my docker image (image1) to EC2 and run a task of specific file (map_process.js) on the image1. Basically the map_process.js file is to run a series of function and create a test1.txt file and log the data inside a test1.txt file. meaning that i have data in text1.txt file. then i run the 2nd task (upload_test1.js) to S3. But i coudn't upload it due to no such file exist. I'm pretty sure my code doest not have problems is because i try ssh into the server and run those task and the file is created and upload successfully.

So i suspect that everytime i run the task, the image is the "fresh". that mean when run map_process.js task create the test1.txt file. Then i run upload_test1.js the image is a "fresh" without the previous task the create the file.

How can i solve this problems? please advice