Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Boaz Keren Gil
Boaz Keren Gil
18,947 Points

Sass --watch stopped working

Hello, I'm using Sass 3.4.5 (Selective Steve) on Mac, and when I --watch my dropbox folder and even the desktop it won't change the CSS file when I make changed to the SCSS file. Yesterday it worked like a charm, and today It just won't update it upon file change.

A quick note: it does update the CSS file, but it seems with a delay of 15-20 minutes.. obviously I can't work with that.

Anyone know what the problem might be?

Thanks, Boaz

3 Answers

Try adding the input/output arguments to the terminal command:

sass --watch path/sass-directory:path/css-directory

Or for a particular file:

sass --watch path/sass-directory/styles.scss:path/css-directory/styles.css

Using Sass | Sass Documentation

If you've only got one SCSS file, that should make it much quicker... perhaps something else in those directories is causing it some issues?

Boaz Keren Gil
Boaz Keren Gil
18,947 Points

It worked. I used the input/output option because i'm working on many files. Thank you very much!

By the way, just so i know - when I uninstall Sass, Do I need to remove to gem, or only sass?

Thanks, Boaz.

Are you specifying the input SCSS file and output CSS file in the command line?

Are you importing any large SCSS libraries or anything? Try with or without them.

Otherwise, maybe a good 'ol computer restart might help, since you said it worked properly yesterday?

Boaz Keren Gil
Boaz Keren Gil
18,947 Points

I'm not using SCSS Libareries, and not specifying any input and output. I just started coding with Sass so i'm pretty new.

I'll try restart and reinstall Sass, hopefully it will work.

Regarding uninstalling, I think they are the same thing.

You should be using the following to uninstall Sass anyways...

gem uninstall sass