Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Android Build an Interactive Story App (Retired) User Input Creating the Project

sdk tools directory is missing, Android Studio wont run

I downloaded the latest version of android studio. It installed however when I run I get two lines...

"Android SDK was installed to C:\Users\AppData\Local\Android\sdk SDK tools directory is missing"

Then I click finish and it closes, every time I run this happens.

Please help

I made some progress, I clicked 'x' instead of finish and it let me start android studio. so I can now go into configure -> Project Defaults -> Project Structure and in here it lets me specify the sdk folder, only the sdk folder is not where it says it is in the text above...there is no 'AppData' folder in 'Users'.

So any ideas where else the sdk folder could be? Or any other ways to fix this?

3 Answers

Courses Plus Student 21,474 Points

Try uninstalling and reinstalling the latest version of Android Studio into somewhere where you have at least 5gb of space.

I did this but no luck.

Lalu Diwal
Lalu Diwal
4,580 Points

Ok so first go to configure afterwards click on sdk manager take that sdk path copy it and go to configure --> project defaults-->project structure and add it into the android sdk location path there you go