Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP PHP Basics Daily Exercise Program Conditionals

Separate if statements

What do separate if statements look like? I have tried this exercise and the "Check Work" says I need to separate the if statements. What do I do?

index.php
<?php
$studentOneName = 'Dave';
$studentOneGPA = 3.8;

$studentTwoName = 'Treasure';
$studentTwoGPA = 4.0;

//Place your code below this comment
if ($studentOneGPA == 4.0) {
  echo "$studentOneName made the Honor Roll";
} elseif ($studentOneGPA != 4.0) {
  echo "$studentOneName has a GPA of $studentOneGPA. ";
}

if ($studentTwoGPA == 4.0) {
  echo "$studentTwoName made the Honor Roll";
}  
  elseif ($studentTwoGPA != 4.0) {
  echo "$studentTwoName has a GPA of $studentTwoGPA";
}
?>

2 Answers

Dave StSomeWhere
Dave StSomeWhere
19,822 Points

The issue is that the challenge is asking for you to use ELSE (in bold) and not ELSEIF.

<?php
//  Your code - might work - not elegant
//  Yucky, since the elseif will only happen when 
//  Student 1 GPA != 4.0
if ($studentOneGPA == 4.0) {
  echo "$studentOneName made the Honor Roll";
} elseif ($studentOneGPA != 4.0) {
  echo "$studentOneName has a GPA of $studentOneGPA. ";
}

// Elegant acceptable solution - cleaner and easier to read/follow
if ($studentOneGPA == 4.0) {
  echo "$studentOneName made the Honor Roll";
} else {
  echo "$studentOneName has a GPA of $studentOneGPA. ";
}
?>

Oh, ok, yes that code is a lot more streamlined. Thanks for helping out.