Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Build a Rails API Namespacing Routes and JSON Checking our API with cURL

Brian Patterson
Brian Patterson
19,588 Points

Shame about this tutorial

It's a real shame that this tutorial is not updated. As when I try to run bundle I get this error

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.

It basically means that app is not usable. It would have been great if she started from scratch.

David O' Rojo
David O' Rojo
11,051 Points

To be fair, it is not a tutorial on «solving dependency errors». But if you share the complete error message, the community may help you to solve the issue.

2 Answers

Brandon McClelland
Brandon McClelland
4,645 Points

Run bundle update && bundle install to see if you can get gem to properly install the json version you need.

I ran 'bundle update json' and that worked fine for me...gdluck!