Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS Functions in Swift Functions in Swift Recap: Functions

Shouldn't this function be called temperatureInCelsius if Celsius is the input we're seeking?

In this task we're going to write out code to take a Celcius temperature value passed in and convert it to Fahrenheit. To convert from Celcius to Fahrenheit - multiply the value by 9, divide the resulting value by 5 and then add 32. Once you have the Fahrenheit value, return it from the function.

When I change it to temperatureInCelsius however, it says that the function should be called temperatureInFahrenheit. Help!

functions.swift
func temperatureInFahrenheit(temperature: Double) -> Double {

    temperatureInFahrenheit = temperatureInCelsius / 9 * 5 + 32

    return(temperatureInFahrenheit)
}

1 Answer

Essentially, you can call functions whatever you want for any user-defined functions, but if it is dependent on being called a particular thing for it to work with other existing code (or for a test/challenge medium like Treehouse) then it's going to require, and oftentimes state in the exercise/question, what it should be called . In this case, it expects your function to be named temperatureInFahrenheit() because the code calls your function calls a function by that name. Also, it's worth mentioning that a function usually is named for what the function does or the values returned. Since this one is returning the temperature in Fahrenheit, it is named the way it is for clarity (though it's debatable whether the naming convention is the best one they could have used)

Got it, thanks!