Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Jack Campbell
Jack Campbell
1,822 Points

Simulator in use? URGENT

Ok so I am making the ribbit app and it was working just a second ago. Now it is saying simulator in use. (The Simulator can't be launched because it is already in use.) This doesn't make sense because it is not running. Does anyone know how to fix this?

1 Answer

John Beatty
John Beatty
7,125 Points

I've normally solved the problem by a) restarting the simulator or b) restarting xCode.

In the case of a), a make sure that the simulator program is actually shut down, not just closed. Closing the simulator window does NOT terminate the simulator program. Just command-tab over to the Simulator icon and then use the menu to quit.

That is what has worked for me in the past. Hope this helps!