Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

JavaScript jQuery Basics (2014) Creating a Mobile Drop Down Menu Perform: Part 1

[SOLVED] Dropdown menu does not show up after appending the select

I cannot find what the problem might be. Here is what I have in app.js:

var $select = $("<select></select>");

Hi Rebekah,

There's nothing wrong with the code you posted. Can you show us the HTML?

Thanks Robert! Here is the HTML:

<!DOCTYPE html>
<link rel="stylesheet" href="css/style.css" type="text/css" media="screen" title="no title" charset="utf-8">
    <div id="menu">
            <li class="selected"><a href="index.html">Home</a></li>
            <li><a href="about.html">About</a></li>
            <li><a href="contact.html">Contact</a></li>
            <li><a href="support.html">Support</a></li>
            <li><a href="faqs.html">FAQs</a></li>
            <li><a href="events.html">Events</a></li>
    <p>This is the home page.</p>
    <script src="http://code.jquery.com/jquery-1.11.0.min.js" type="text/javascript" charset="utf-8"></script>
    <script src="js/app.js" type="text/javascript" charset="utf-8"></script>

I checked and JavaScript is enabled and my app.js is in the js folder. I downloaded the files and the complete project works on my localhost. 20 minutes later... I found it! lol It was a tiny little ` right next to one of the comments. I saw it in developer tools while checking out the source code. Thanks so much for the help Robert!

2 Answers

Glad it's working!

Updated thread to solved.

I'm not able to reproduce the problem. I get an empty select menu, just like in the video.

  • Is your app.js file inside the js folder?
  • Is your browser using a script blocker?