Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS Installing and Using CocoaPods for iOS

Jason Anders
Jason Anders
Treehouse Moderator 145,858 Points

[Solved] Getting an error when trying to set up pods?

I've spend the past hour searching for a solution, but have come up empty. Any ideas Gabe Nadel

The install goes fine, but then setup causes a blow up

[!] ERROR: Parsing unable to continue due to parsing error:
contained in the file located at /Users/<deleted for privacy>/.cocoapods/repos/master/CocoaPods-version.yml
min: 0.32.1
last: 1.1.0.beta.1

/Users/<deleted for privacy>/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/yaml_helper.rb:62:in `rescue in load_string'
/Users/<deleted for privacy>/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/yaml_helper.rb:57:in `load_string'
/Users/<deleted for privacy>/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/yaml_helper.rb:75:in `load_file'
/Users/<deleted for privacy>/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/source/metadata.rb:27:in `from_file'
/Users/<deleted for privacy>/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/cocoapods-core-1.0.1/lib/cocoapods-

plus about 30 more lines of this...
Jason Anders
Jason Anders
Treehouse Moderator 145,858 Points

Solved it, but still in no way sure how I did. I followed some instructions from Stack Overflow... didn't work. Tried suggestions from CocoaPods troubleshooting page. Uninstalled - Re-installed - Uninstalled - Re-installed. Tried with an older version ... tried with a newer version ...

Last ditch effort before I threw my computer out the window ... I just started from step one again ... and this time it all worked. HUH? That was a well spent hour!

So, if anyone has any guess as to why? That'd be awesome. For now, it get chalked up to my sometimes not-so-friendly-digital gremlin. :)