Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP

Maciej Sitko
Maciej Sitko
16,164 Points

Stuck on Laravel Basics, reason being Vagrant not working properly

I use Linux Xubuntu 14.04 and I configured everything that I literally could. But when I run Vagrant using vagrant up

it freezes on:

default: Waiting for machine to boot. This may take a few minutes...

    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Error: Connection timeout. Retrying...
    default: Error: Connection timeout. Retrying...
    default: Error: Connection timeout. Retrying...
    default: Error: Connection timeout. Retrying...
    default: Error: Connection timeout. Retrying...

Keeps retrying until it times out.

How can I fix it? I can imagine it could be a problem of my BIOS not having virtualization enabled, but I cannot do that inside my BIOS, when i ran sudo kvm-ok it simply gave me:

```INFO: Your CPU does not support KVM extensions KVM acceleration can NOT be used

Would that be the possible reason of Vagrant not working? If so, what is this tutorial made totally uncompatible to different setups, now I'm pretty muich in a dead end, and what, forced to buy a new PC setting up a new dev environment? Huh

**Edit: Couldn't get that to work, had to switch the PCs to the one with CPU actually supporting VT-x, and therefore virtualization. For future reference, PLEASE make me, and every other user, aware that this set up would work only with new/newer machines that were bought preferably after 2012, and that fully support VT-x in a CPUwise way. That information is non-existent during the whole tutorial, and I believe that there should be an alternative. You needn't Vagrant/Homestead to set up a normal apache2 virtual host with Laravel on it.**

Same problem here. Need a solutions or an alternative.

Maciej Sitko
Maciej Sitko
16,164 Points

There is not going to be solution other than hardware upgrade.

Double check in your BIOS under the Advanced tab if you have a Virtualisation option available (could be also written as VT-x). If you do, enable that and Vagrant shall run, otherwise, your CPU does not support virtualisation.

I did what you said maciejsitko in the bios now the computer is saying over clocking failed change settings. When I change it back same problem. Need help

Maciej Sitko
Maciej Sitko
16,164 Points

You mean that after changing the settings you still get overclocking error or 'Connection Timeout'?

Over clocking error comes up when I try and start my computer after making changes to enable virtualisation in the bios and asks me to make changes in the bios then restart

Maciej Sitko
Maciej Sitko
16,164 Points

Firstly, try putting BIOS back into to default config mode.

If not, try to disable Ai Overclock and then enable XMP in BIOS.